ZF2-246: Paginator needs update due Zend\Db changes

Description

Paginator needs update due Zend\Db changes

Comments

This must wait until Zend\Db is completed

The component has been updated