ZF-6028: ZendX_JQuery_Form_Element_* fails when implemting using a custom view_handler

Description

I'm using smarty as view engine. When trying to use Jquery form i get exception like this :

Fatal error: Uncaught exception 'Zend_Loader_PluginLoader_Exception' with message 'Plugin by name 'UiWidgetElement' was not found in the registry; used paths: ZendX_JQuery_Form_Decorator_: ZendX/JQuery/Form/Decorator/:ZendX/JQuery/Form/Decorator/:ZendX/JQuery/Form/Decorator/ Zend_Form_Decorator_: Zend/Form/Decorator/:Zend/Form/Decorator/' in /usr/local/share/ZendFramework/library/Zend/Loader/PluginLoader.php:390 Stack trace:

0 /usr/local/share/ZendFramework/library/Zend/Form/Element.php(1702): Zend_Loader_PluginLoader->load('UiWidgetElement')

1 /usr/local/share/ZendFramework/library/Zend/Form/Element.php(2061): Zend_Form_Element->_getDecorator('UiWidgetElement', NULL)

2 /usr/local/share/ZendFramework/library/Zend/Form/Element.php(1852): Zend_Form_Element->_loadDecorator(Array, 'UiWidgetElement')

3 /usr/local/share/ZendFramework/library/Zend/Form/Element.php(1908): Zend_Form_Element->getDecorators()

4 /usr/local/share/ZendFramework/library/Zend/Form/Decorator/FormElements.php(100): Zend_Form_Element->render()

5 /usr/ in /usr/local/share/ZendFramework/library/Zend/Loader/PluginLoader.php on line 390

Just a normal form works fine. I've implemting the form like this :

$oDate = new ZendX_JQuery_Form_Element_DatePicker( "datePicker1", array("label" => "Date Picker:") ); $oDate->setJQueryParam('dateFormat', 'dd.mm.yy'); $oForm->addElement($oDate);

I've added ZendX_JQuery::enableForm($oForm);

IN the bootstrap i've added :

$oSmarty->addHelperPath("ZendX/JQuery/View/Helper", "ZendX_JQuery_View_Helper");

The file ZendX/JQuery/Form/Decorator/UiWidgetElement.php exists and is readable.

Comments

If you need any help, other example or info. Please let me know, because i can't create a workaround to solve this problem.

How do you include ZendX files for usage? how does your include path setup look like? I think this maybe an issue of wrongly configured include paths

Cannot reproduce the issue and no further feedback was provided. Re-open if necessary.