Issues

ZF-5167: Warnings generated if Zip extention is not installed

Description

Zend/Search/Lucene/Documents/Docx.php, OpenXml.php, Pptx.php and Xlsx.php all have a line like this:

 
if (class_exists ( 'ZipArchive' )) {

On systems where the Zip extension is not loaded, this generates the warning:

Warning: Zend_Loader::include_once(ZipArchive.php) [zend-loader.include-once]: failed to open stream: No such file or directory in /Users/rob/ZFiA/code/lib/Zend/Loader.php on line 89

Fix is to change the class_exists() call to:

 
if (class_exists ( 'ZipArchive' , false)) {

Comments

Fixed in r13040 on trunk and r13041 on release-1.7 branch.